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1 

Chapter 1: Overview 
  
Noventri Digital Signage Software 
Noventri Digital Signage Software has two parts, the Noventri Suite Software and the Noventri Server 
Software.   
 
Noventri Digital Signage Software - Suite 
Noventri Suite Software is used for the design of Projects, and is the user interface for the Server (used 
for managing content and for controlling what is displayed by the Players). For more information, see the 
Noventri Suite manuals. 

 
Noventri Digital Signage Software - Server 
Noventri Server Software contains three components that are installed together:   

 
Server - The Server is the main Server that runs in the background and accepts  connections from 
 Noventri Suite installations and Players, and acts as an interface between the two. For more 
 information, see the Server section of this manual; Chapter 2.  
 
Server Manager  - The Server Manager is also a "server" that runs in the background. It manages the 
 "main" Server(s) and accepts connections from the Server Manager Tray. For more 
 information, see the Server Manager section of this manual; Chapter 3.  
 
Server Manager Tray - The Server Manager Tray is accessed via the Noventri Server icon on the 
 desktop and is the user interface for the Server Manager. For more information, see the Server 
 Manager Tray section of this manual; Chapter 4. 
 
Network Note:  Active access to files across a network by the Noventri Server (for example, accessing a 
 Database File) is allowed only if Windows service properties are configured correctly. For more 
 information, see the Network Considerations section of this manual; Chapter 5. 
 
  
Installation 
Installation instructions for both Noventri Suite Software and Noventri Server Software are covered in 
the Noventri Suite Design manual. For more information, see the Noventri Suite - Design Manual. 
 
Noventri Server Software can be installed on the same computer as the Noventri Suite Software or can 
be installed on a separate computer. 

 
 
 
 
 

http://www.noventri.com/forum
http://www.noventri.com/forum
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2 
Chapter 2: Server 

 
Server - Summary 
The Server is the main Server that runs in the background and accepts connections from Players and 
Noventri Suite instances, acting as an interface between the two. The Server manages; Players, Users, 
and relevant files for distributing content to the Players. It distributes the content as required to the 
Players and provides information through Noventri Suite to the user. 
  
When Noventri Server Software is installed, it automatically defaults to having one Server created and 
ready to use (Port 20940).  
 
When the computer, with the Noventri Server Software is turned on, the Server automatically runs in the 
background. 
 
The Server needs to be in communication with the Players and with Noventri Suite for proper operation. 

 
 

Server Connection to Players 
Players can be pointed to the Server by opening the Players Web-App and setting the Player's  
Noventri Server field to the IP address (of the computer where the Noventri Server software is installed), 
followed by the Port (default 20940). For more information, see the Noventri SF-200 Manual.  

 
 

Server Connection to Suite 
Noventri Suite connects to the Server, enabling Noventri Suite to access the Players. This connection is 
acquired from within Noventri Suite. Selecting anything within the Noventri Suite program that requires a 
connection to the Server will prompt a Server Login.   
 

 
 
 
This will automatically open a Server Login window. If the Server and the Suite are installed on the same 
computer, the default login information is as shown below. For more information, see the Noventri Suite - 
Design Manual. 

 
    Host:   localhost 
    Username: Admin 
    Password: noventri 

 
 

http://www.noventri.com/forum
http://www.noventri.com/forum
http://www.noventri.com/forum
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Server Operation 
Once the Server is connected to both Player(s) and Noventri Suite, it needs no additional configuration 
for basic operation. For more information, see the Noventri Suite Manuals. 

 
More advanced Server configuration is accessible through the Server Manager. For more information, 
see the Server Manager section of this manual; Chapter 3. 

 

http://www.noventri.com/forum
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3 
Chapter 3: Server Manager 

  
Server Manager - Summary 
The Server Manager is used for advanced Server configuration, such as creating additional Servers and 
configuring their settings. 
 
When the Noventri Server Software is installed, the Server Manager is automatically installed. 
 
The Server Manager, like the Server, is also a "server" that runs in the background. However, the Server 
Manager interacts with Windows as a service. 
 
 
The Server Manager accepts connections from the Server Manager Tray (user interface), and using the 
Server Manager Tray input, manages the Servers.  
  

 
Server Manager connection with the Server Manager Tray 
The connection between the Server Manager and the Server Manager Tray is done from within  the 
Server Manager Tray. For more information, see the Server Manager Tray section of this manual; 
Chapter 4. 
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4 
Chapter 4: Server Manager Tray 

 
Server Manager Tray - Summary 
The Server Manager Tray is the user interface for the Server Manager. 
  
The Server Manager Tray via the Server Manager is used for advanced Server configuration, such as 
creating additional Servers and configuring their settings. 
 
When the Noventri Server Software is installed, the Server Manager Tray is automatically installed as 
part of it. 

 
 

Server Manager Tray connection to the Server Manager 
The Server Manager Tray is accessed from the Noventri Server icon on the desktop (default location). 
When the Server Manager icon is selected the Noventri Server Manager Login window will open. 
 

 
 

Server Manager Login Window 
The Noventri Server Manager Login window is used to login to the Server Manager.  
 

 
 
The default login information.... 
 
 Service Manager: localhost 
 Port:   20939 
 Password:  noventri 
 
 
Note 1: The Server Manager that is being logged into can be located on the same computer as Server 
 Manager Tray or can be located on a separate computer. 
 
Note 2: Toolbar commands for the Server Manager Login Window and the Server Manager Main 
 Window are basically the same. For more information, see the Toolbar section of this manual. 
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Service Manager – In the Service Manager box, enter the IP Address of the computer where the Server 
 Manager is located. The IP Address can be entered manually or can be selected from the drop 
 down menu. If the Server Manager Tray and the Server Manager are located on the same 
 computer, use localhost (default). 
 

 
 

 
Note: When logging into a Server Manager that is not located on the same computer; access is only 
 allowed if the Server Manager on the other computer has its Remote Administration option 
 enabled. For more information, see the Advanced Tab section of this manual. 

 
 
Port –  In the Port box, enter the Port number. Just as the Server has a Port number; with the localhost 
 default being 20940, the Server Manager also has a Port number; with the localhost default being 
 20939.  
 

 
  
  

Password – In the Password box, enter the Password for the Server Manager. The default Password is 
noventri. 
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Once all the Login information is correct, select the Login button, or to close the window without logging 
in, select the Cancel button. 

 

 
 
 
Note:  Selecting the Cancel button will close the window; however the Server Manager Tray will remain 
 active with its icon in the Windows System Tray. 
 

 
 
 

Once the Login is successful, the Noventri Server Manager window will open. For more information, see 
the Server Manager Main Window section of this manual. 
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Server Manager Main Window 
Once the Login is successful, the Noventri Server Manager main window will open.  
 

  
 
 

Note: Toolbar commands for the Server Manager Login Window and the     
 Server Manager Main Window are basically the same. For more     
 information, see the Toolbar section of this manual. 

 
 
Servers Tab 
The Servers tab is where individual Servers are listed and handled. In this tab, Severs can be 
Added/Removed or Started/Stopped. 
 
When the Noventri Server Software was installed, a default Server was automatically created at Port 
20940. 
 
The Server stats panel shows the automatically created default Server along with any other Servers that 
are controlled by this Server Manager.  
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The Server stats panel has columns showing the settings for each of the Servers. 
 
Auto - When the Auto check box is selected; that Server will automatically run in the background when 
 the computer is turned on.  
  

 
 
 
Name - The Server that was automatically created when the Noventri Server Software was installed is 
 Named - Default. Any additional Servers that are created will be Named – New Server. 

   

 
 
 
To change the Name of any of the Servers, double click on the Name and it will become an editable text 
box, where a new Name can be typed in. 
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Port - The Port for the Server that was automatically created when the Noventri Server Software was 
 installed is 20940. Any additional Servers that are created will be assigned Port numbers 
 sequentially. No two Servers on the same computer may share the same Port number. 

 

 
 
 
To change the Port of any of the Servers, double click on the Port and it will become an editable text box, 
where a new Port number can be selected. 
 

 
 
 
Sync Interval - The Sync Interval for all Servers defaults to 900mS (.9 seconds). This is the time interval 
 of how often the Status shown on this panel will receive an update from the Server.  
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To change the Sync Interval for any of the Servers, double click on the Sync Interval and it will become 
an editable text box, where a new Sync Interval in mS can be selected. 

 

 
 
 
Status - The Status column shows the current Status for each Server. The Status is received from the 
 Player.  

 

 
 
 

   
The Servers tab also has a list of command buttons on the left. 
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Start - The Start button is used to start a Server. When a Server is started, its Status will change to 
 Running. The Server will then be the interface between the Players and Noventri Suite 
 installations that are connected to it.  

 

 
 

 
Stop -  The Stop button is used to stop a Server that is Running. When a Server is stopped, its Status 
 will change to Not Running and it will no longer be connected to any of the Players or Noventri 
 Suite installations.  

 

 
 
 

Restart - The Restart button is used to restart a Server that is Running. When a Server is restarted, it 
 will temporarily stop and then start again. Its Status will eventually go back to Running once it has 
 fully restarted.  
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Add Server - The Add Server button allows multiple Servers to be created. As Servers  are created they 
 will automatically be assigned Port numbers sequentially. Each Server will be completely 
 independent of the others.  
 

 
 
 

Remove Server - The Remove Server button allows Servers to be removed. Select the Server and then 
 press the Remove Server button. 
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Browse Files\Browse Logs - The Browse Files\Browse Logs buttons allow access to the Noventri 
 Suite and Player files that are saved on the Server. Unlike viewing Server files from within 
 Noventri Suite (where only specific files are viewable), when viewing them through the Server 
Tray, the entire tree structure is visible, therefore all files can be seen.   
 

Note:  Although the Files/Logs for all the Servers can be browsed here. When viewing    
 Server Files/Logs through Noventri Suite installations, the only files accessible will be   
 for the Server the Suite is connected to.  
 

      
 
Note: When Browsing to a location on the network, be sure to always use the UNC Path (Universal 
Naming Convention, which typically contains (\\server...). Do not use a path containing a shortcut (such as 
m:\).   

 
 

Advanced Tab 
In the Advanced tab, the Work/Log Directory locations for the "main" Servers can be changed. The 
Password/Port/Remote access can be changed for the Server Manager "server", or the Server 
Manager Tray can be set to automatically open (on boot up) in the Windows Start Tray. 
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Work Directory - The Work Directory is the location where files used by the "main" Server(s) are stored. 
 This includes Project files, Schedules, Images, etc. Within this directory, each Server will have a 
 separate sub folder. It is recommended to use the default location; however the location can be 
 changed here by selecting the Browse button and browsing to the desired new location, and then 
 selecting OK.  
 
Note: When Browsing to a location on the network, be sure to always use the UNC Path (Universal 
Naming Convention, which typically contains (\\server...). Do not use a path containing a shortcut (such as 
m:\).   

 

 
 
 
Log Directory - The Log Directory is the location where Log files are stored by the "main" Server(s).  
  Within this directory each Server will have a separate sub folder. It is recommended to  
  use the default location; however the location can be changed here by selecting the  
  Browse button and browsing to the desired new location, and then selecting OK.  
 
Note: When Browsing to a location on the network, be sure to always use the UNC Path (Universal 
Naming Convention, which typically contains (\\server...). Do not use a path containing a shortcut (such as 
m:\).   
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Password - The Current/New/Confirm Password boxes allow the Server Manager "server" Password 
 to be changed. The default Password is noventri.  

 

 
 
 
Administration Port - The Administration Port is the Port for the Server Manager "server". Just as the 
 "main" Server(s) have a Port numbers; with the localhost default being 20940, the Server  
 Manager "server" also has a Port number; with the localhost default being 20939. The 
 Administration Port box allows the Port for the Server Manager "server" to be changed.  

 

 
 
 
Remote Administration - The Remote Administration option allows this Server Manager "server" to be 
 logged into from Server Managers Trays located on other computers. Select the Remote 
 Administration check box to allow these remote connections. 
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Start Tray on Boot – When the Start Tray on Boot option is selected, the Server Manager Tray will 
 automatically open (on boot up) and be hidden to the Windows Start Tray.  
  

 
 
 
Apply/Cancel - Once all the information is correct in Noventri Server Manager main window (Servers 
 tab and Advanced tab), select the Apply button to save, or to close the window without saving, 
 select the Cancel button. 

 
 
Toolbar  
The toolbar commands for the Server Manager Login Window and the Server Manager Main Window 
are basically the same.  
 
File > Hide to Tray – This option will close the window, and cause the Server Manager Tray icon to be 
 displayed in the Windows System Tray.  
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File > Exit – This option will also close the window, however the Exit option will truly close the Server 
 Manager Tray application and its icon will not be displayed in the Windows System Tray.  

The keys Alt-F4 can also be used. 
 

  
 
 
 
 

File > Logout – This option will close the Server Manager Main Window and return to the Server 
 Manager Login Window. 

 

 
 
 
Help > Check for Updates – This option will direct you to the Noventri web site, 
www.noventri.com/forum where the current Noventri Server Software can be downloaded. 
 

 
 
 
 
 
 
 
 
 

http://www.noventri.com/forum
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Help > Noventri Support – This option will direct you to the Support Center on our web 
site: www.noventri.com/forum.  
 

 
 
 
Help > About – This option will open a window that shows the current Contact 
information for Noventri, License Agreement, and the Noventri Server – Version 
being used. The F1 key can also be used. 
 

  
 
 
 
 
 
 

http://www.noventri.com/forum
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5 
Chapter 5: Network Considerations 

  
Network Considerations - Summary 
Active access to files across a network by the Noventri Server is allowed only if Windows service 
properties are configured correctly. Files that need to be actively accessed across a network include 
Database Files and also any Image or Text files that are chosen to not be copied to the Server. 
 
Windows service properties need to be configured so the Server is allowed access to the files on a regular 
basis. This is done by setting the Service Manager "server" (service) to User instead of Local System.  
 
 
Windows Service - General 
If a Service is automatically started (when the computer is turned on) the default state of the Service will 
be to run as a Local System - Service. Any Process started by the Service will run as a System - 
Process. In this state they will not have permission to access files across the network. 
 
To have permission to access files across the network, the Service needs to run as a User – Service 
instead of a Local System – Service. This in turn will cause its Process to run as a User – Process 
instead of a System – Process. 
 
A Service and therefore its Process will run in a User state if it is started manually, or if it is specifically 
configured to automatically start (when the computer is turned on) as a User – Service. 
 

 
Noventri Server Manager – System Service/Process 
When the Noventri Server components are installed, the Server Manager is will automatically run as a 
Windows Service (when the computer is turned on) and by default will be a Local System – Service and 
therefore a System - Process also. Any main Noventri Servers managed by this Server Manager will 
have the same permission limitations. 
 
 
Service state can be seen in the Windows Service window... 
Start > Settings > Control Panel > Administrative Tools > Services > Noventri Server Manager  
 

 
 
 
 
 
 
 
 
 
 
Process state can be seen in the Windows Task Manager window... 
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Ctrl+Alt+Del > Processes > NDS_SM.exe  
 

 
 
 
 
Noventri Server Manager – User Service/Process 
To change the Noventri Server Manager to automatically run (when the computer is turned on) with its 
Service and Process in a User state, and therefore be allowed permission to access files over the 
network, the Service properties have to be updated. 
 
Navigate to the Service... 
 
Start > Settings > Control Panel > Administrative Tools > Services > Noventri Server Manager  
 

 
 
 
Double click on it to open its properties window then select the Log On tab... 
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Select the This Account radio button, fill in the account as User, and enter the computer Password, select 
Apply, and then OK. 
 
Note: The account User will automatically be changed to the correct format once Apply is selected. 
 

   
 
 
The Service will now need to be Stopped and re-Started under the General tab for the change to take 
effect... 
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The Service will now run as a User – Service instead of a Local System – Service and the Process will 
run as a User – Process instead of a System – Process. Database files or Image/Text files can now be 
actively accessed over the network without having to copy them to the Server.  
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